Back to overview
Degraded
Babylon Genesis stability issues
Jun 19 at 01:27am GMT+3
Affected services
btc.union.build
Updated
Jun 19 at 01:41pm GMT+3
Babylon Genesis stability has improved, however we are continuing to monitor the situation.
Affected services
btc.union.build
Created
Jun 19 at 01:27am GMT+3
Babylon Genesis is currently experiencing stability issues. Service on all routes may be degraded.
Affected services
btc.union.build